NodeJS – npm

Installation

Se rendre sur le site https://nodejs.org/en/, télécharger et installer l’exécutable pour WIndows 64-bits.

Uniquement sur le pc bureau; configurer npm derrière le pare-feu du bureau :

 npm config set proxy http://USER_BUREAU:PWD_BUREAU@tmgproxy.yourict.net:8080

Vérification de la version

 npm -v

Messages d’erreur

À l’installation d’un package (p.ex. npm i --save puppeteer), un message d’erreur tel que ci-dessous peut s’afficher.

Ce message indique que la version de NPM n’est plus supportée et pas un problème avec le package qu’on souhaite installer.

Le code ELIFECYCLE se rapporte à NPM. Le numéro de version mentionné (v2.15.9) est celui de NPM...

(En février 2018, la version de NPM est 5.6.0)

npm ERR! npm  v2.15.9
npm ERR! code ELIFECYCLE

npm ERR! puppeteer@1.0.0 install: `node install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the puppeteer@1.0.0 install script 'node install.js'.
npm ERR! This is most likely a problem with the puppeteer package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs puppeteer
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR!     npm owner ls puppeteer
npm ERR! There is likely additional logging output above.